NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

Llama Stack exposes secret in initialization logGHSA-xmfj-7pp5-fxr6

LOWFix: llamastack/llama-stack@b709bd7

GHSA-xmfj-7pp5-fxr6 is a low-severity (CVSS 3.2) CWE-532 vulnerability in llama-stack. A fix is available for llama-stack — see the affected versions and patch details below.

Also known asCVE-2026-25211PYSEC-2026-1572
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-xmfj-7pp5-fxr6.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.25%0.49%0.74%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍llama-stack

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIllama-stackall versions0.4.4pip install --upgrade 'llama-stack==0.4.4'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for llama-stack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update llama-stack to 0.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xmfj-7pp5-fxr6 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

The vulnerability has a Low impact.The flaw involves information exposure through log files in the Llama Stack server when PGVector is configured, where database passwords are logged in plaintext.

Workaround published by Red Hat
To mitigate this issue, ensure strict access controls are implemented for server and application logs associated with Llama Stack deployments. Restrict log file and directory access to authorized personnel only to prevent unauthorized disclosure of sensitive database credentials. Consider integrating log redaction or encryption solutions if supported by your logging infrastructure for enhanced data protection.
Source: Red Hat security advisory for GHSA-xmfj-7pp5-fxr6 (CC BY 4.0)

Frequently Asked Questions

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.
O3 Security · Impact-Aware SCA

Is GHSA-xmfj-7pp5-fxr6 in your dependencies?

Find it across PyPI, including transitive dependencies.

Llama Stack exposes secret in initialization log (Low 3.2)