NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2026-25211 — llama-stack

LOWFix: llamastack/llama-stack#4439

CVE-2026-25211 is a low-severity (CVSS 3.2) CWE-532 vulnerability in llama-stack. A fix is available for llama-stack — see the affected versions and patch details below.

Llama Stack exposes secret in initialization log

Also known asGHSA-xmfj-7pp5-fxr6PYSEC-2026-1572
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25211.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.25%0.49%0.74%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍llama-stack

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIllama-stackall versions0.4.4pip install --upgrade 'llama-stack==0.4.4'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for llama-stack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update llama-stack to 0.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25211 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.
O3 Security · Impact-Aware SCA

Is CVE-2026-25211 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-25211: llama-stack — Fixed in 0.4.4