NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Keylime allows users to register new agents by recycling existing UUIDs when using different TPM devicesGHSA-xh5w-g8gq-r3v9

HIGHFix: keylime/keylime#1785

GHSA-xh5w-g8gq-r3v9 is a high-severity (CVSS 8.2) CWE-694 vulnerability in keylime. A fix is available for keylime — see the affected versions and patch details below.

Also known asCVE-2025-13609PYSEC-2025-77
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-xh5w-g8gq-r3v9.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍keylime

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability has been identified in keylime where an attacker can exploit this flaw by registering a new agent using a different Trusted Platform Module (TPM) device but claiming an existing agent's unique identifier (UUID). This action overwrites the legitimate agent's identity, enabling the attacker to impersonate the compromised agent and potentially bypass security controls.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeylimeall versions7.13.0pip install --upgrade 'keylime==7.13.0'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keylime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keylime to 7.13.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xh5w-g8gq-r3v9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability is rated Important for Red Hat products as the Keylime registrar allows an attacker to perform an identity takeover. By registering a new agent with a duplicate UUID, an attacker can overwrite an existing agent's identity, enabling impersonation and potential bypass of security controls. This…

Workaround published by Red Hat
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update the affected package as soon as possible.
Source: Red Hat security advisory for GHSA-xh5w-g8gq-r3v9 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10keylime-0:7.12.1-11.el10_1.3RHSA-2025:23201
Red Hat Enterprise Linux 10.0 Extended Update Supportkeylime-0:7.12.1-2.el10_0.4RHSA-2026:0429
Red Hat Enterprise Linux 9keylime-0:7.12.1-11.el9_7.3RHSA-2025:23210
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionskeylime-0:6.5.2-6.el9_2.1RHSA-2025:23735
Red Hat Enterprise Linux 9.4 Extended Update Supportkeylime-0:7.3.0-13.el9_4.1RHSA-2025:23852
Red Hat Enterprise Linux 9.6 Extended Update Supportkeylime-0:7.3.0-15.el9_6.1RHSA-2025:23628

Frequently Asked Questions

A vulnerability has been identified in keylime where an attacker can exploit this flaw by registering a new agent using a different Trusted Platform Module (TPM) device but claiming an existing agent's unique identifier (UUID). This action overwrites the legitimate agent's identity, enabling the attacker to impersonate the compromised agent and potentially bypass security controls.
O3 Security · Impact-Aware SCA

Is GHSA-xh5w-g8gq-r3v9 in your dependencies?

Find it across PyPI, including transitive dependencies.

Keylime allows users to register new agents by recycling…