CVE-2023-38200 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in keylime. A fix is available for keylime — see the affected versions and patch details below.
Keylime's registrar vulnerable to Denial-of-service attack via a single open connection
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-38200.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keylimeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Keylime registrar is prone to a simple denial of service attack in which an adversary opens a connection to the TLS port (by default, port 8891) blocking further, legitimate connections. As long as the connection is open, the registrar is blocked and cannot serve any further clients (agents and tenants), which prevents normal operation. The problem does not affect the verifier.
Patches
Users should upgrade to release 7.4.0
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keylime | all versions | 7.4.0pip install --upgrade 'keylime==7.4.0' |
Affected Products
fedorafedoraprojectkeylimekeylimeenterprise linuxredhatenterprise linux eusredhatenterprise linux for ibm z systemsredhatenterprise linux for ibm z systems eusredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keylime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keylime to 7.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38200 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 9 | keylime-0:6.5.2-6.el9_2 | RHSA-2023:5080 |
Frequently Asked Questions
Is CVE-2023-38200 in your dependencies?
Find it across PyPI, including transitive dependencies.