NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2022-1053 — keylime

CRITICALFix: keylime/keylime@bd5de71

CVE-2022-1053 is a critical-severity (CVSS 9.1) Improper Input Validation vulnerability in keylime. A fix is available for keylime — see the affected versions and patch details below.

Tenant and Verifier might not use the same registrar data

Also known asGHSA-jf66-3q76-h5p5GHSA-jf66-3q76-h5p5,PYSEC-2022-184
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.32%1.98%0.5%1.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍keylime

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Keylime does not enforce that the agent registrar data is the same when the tenant uses it for validation of the EK and identity quote and the verifier for validating the integrity quote. This allows an attacker to use one AK, EK pair from a real TPM to pass EK validation and give the verifier an AK of a software TPM. A successful attack breaks the entire chain of trust because a not validated AK is used by the verifier. This issue is worse if the validation happens first and then the agent gets added to the verifier because the timing is easier and the verifier does not validate the regcount entry being equal to 1. At this time, there are no known workaround.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeylimeall versions6.4.0pip install --upgrade 'keylime==6.4.0'

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
343536
Application
keylimekeylime
< 6.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keylime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keylime to 6.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1053 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Keylime does not enforce that the agent registrar data is the same when the tenant uses it for validation of the EK and identity quote and the verifier for validating the integrity quote. This allows an attacker to use one AK, EK pair from a real TPM to pass EK validation and give the verifier an AK of a software TPM. A successful attack breaks the entire chain of trust because a not validated AK is used by the verifier. This issue is worse if the validation happens first and then the agent gets added to the verifier because the timing is easier and the verifier does not validate the regcount
O3 Security · Impact-Aware SCA

Is CVE-2022-1053 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-1053: keylime — Fixed in 6.4.0