webpki: Name constraints were accepted for certificates asserting a wildcard nameGHSA-xgp8-3hg3-c2mh
LOWGHSA-xgp8-3hg3-c2mh is a low-severity (CVSS 2.2) CWE-295 vulnerability in rustls-webpki. A fix is available for rustls-webpki — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-xgp8-3hg3-c2mh.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rustls-webpki🦀rustls-webpkiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
rustls-webpki (the Rust webpki fork used by rustls) versions >= 0.101.0 and prior to 0.103.12 and 0.104.0-alpha.6 incorrectly accepted permitted-subtree DNS name constraints for certificates asserting a wildcard name. For example, a name constraint of accept.example.com was treated as satisfied by a certificate for *.example.com, which could feasibly assert reject.example.com — a name outside the permitted subtree. Because name constraints are restrictions applied to otherwise properly issued certificates, the issue is only reachable after signature verification succeeds and requires a misissued wildcard certificate to exploit.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | rustls-webpki | ≥ 0.101.0&&< 0.103.12 | 0.103.12cargo update -p rustls-webpki --precise 0.103.12 |
| 🦀crates.io | rustls-webpki | ≥ 0.104.0-alpha.1&&< 0.104.0-alpha.6 | 0.104.0-alpha.6cargo update -p rustls-webpki --precise 0.104.0-alpha.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rustls-webpki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rustls-webpki to 0.103.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xgp8-3hg3-c2mh is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as having a Low impact because exploitation demands strict preconditions, notably obtaining a cryptographically valid wildcard certificate that has been improperly issued by an authority subject to name constraints. Although multiple Red Hat offerings embed rustls-webpki for certificate…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for GHSA-xgp8-3hg3-c2mh (CC BY 4.0)
Frequently Asked Questions
Is GHSA-xgp8-3hg3-c2mh in your dependencies?
Find it across crates.io, including transitive dependencies.