NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

rustls-webpki: CPU denial of service in certificate path buildingGHSA-fh2r-99q2-6mmg

HIGHFix: rustls/webpki@4ea0523

GHSA-fh2r-99q2-6mmg is a high-severity (CVSS 7.5) vulnerability in rustls-webpki. A fix is available for rustls-webpki — see the affected versions and patch details below.

Also known asRUSTSEC-2023-0053
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🦀rustls-webpki🦀rustls-webpki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

When this crate is given a pathological certificate chain to validate, it will spend CPU time exponential with the number of candidate certificates at each step of path building.

Both TLS clients and TLS servers that accept client certificate are affected.

We now give each path building operation a budget of 100 signature verifications.

The original webpki crate is also affected, see GHSA-8qv2-5vq6-g2g7.

This was previously reported in the original crate https://github.com/briansmith/webpki/issues/69 and re-reported to us recently.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iorustls-webpkiall versions0.100.2cargo update -p rustls-webpki --precise 0.100.2
🦀crates.iorustls-webpki≥ 0.101.0&&< 0.101.40.101.4cargo update -p rustls-webpki --precise 0.101.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rustls-webpki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rustls-webpki to 0.100.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fh2r-99q2-6mmg is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

When this crate is given a pathological certificate chain to validate, it will spend CPU time exponential with the number of candidate certificates at each step of path building. Both TLS clients and TLS servers that accept client certificate are affected. We now give each path building operation a budget of 100 signature verifications. The original `webpki` crate is also affected, see [GHSA-8qv2-5vq6-g2g7](https://github.com/advisories/GHSA-8qv2-5vq6-g2g7). This was previously reported in the original crate <https://github.com/briansmith/webpki/issues/69> and re-reported to us recently.
O3 Security · Impact-Aware SCA

Is GHSA-fh2r-99q2-6mmg in your dependencies?

Find it across crates.io, including transitive dependencies.

rustls-webpki: CPU denial of service in certificate path…