NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Struts vulnerable to possible DoS attack when using URLValidatorGHSA-xg75-68x3-7p3q

MEDIUMFix: apache/struts@a0fdca1

GHSA-xg75-68x3-7p3q is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in org.apache.struts:struts2-core. EPSS puts its 30-day exploitation probability at 10.4% (96th percentile). A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.

Also known asCVE-2016-4465
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
9.78%10.2%10.7%11.1%10.4%10.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.struts:struts2-core☕org.apache.struts:struts2-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.13 allows remote attackers to cause a denial of service via a null value for a URL field.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.struts:struts2-core≥ 2.3.20&&< 2.3.292.3.29org.apache.struts:struts2-core:2.3.29
☕Mavenorg.apache.struts:struts2-core≥ 2.5.0&&< 2.5.132.5.13org.apache.struts:struts2-core:2.5.13

Affected Products

1 product · 12 configurations
Application
strutsapache
9 versions
2.3.202.3.20.12.3.20.32.3.242.3.24.12.3.24.32.3.282.3.28.12.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.struts:struts2-core to 2.3.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xg75-68x3-7p3q is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.13 allows remote attackers to cause a denial of service via a null value for a URL field.
O3 Security · Impact-Aware SCA

Is GHSA-xg75-68x3-7p3q in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Struts vulnerable to possible DoS attack when…