CVE-2016-4465 is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in org.apache.struts:struts2-core. EPSS puts its 30-day exploitation probability at 10.4% (96th percentile). A fix is available for org.apache.struts:struts2-core — see the affected versions and patch details below.
Apache Struts vulnerable to possible DoS attack when using URLValidator
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.struts:struts2-core☕org.apache.struts:struts2-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.1 allows remote attackers to cause a denial of service via a null value for a URL field.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.struts:struts2-core | ≥ 2.3.20&&< 2.3.29 | 2.3.29org.apache.struts:struts2-core:2.3.29 |
| ☕Maven | org.apache.struts:struts2-core | ≥ 2.5.0&&< 2.5.13 | 2.5.13org.apache.struts:struts2-core:2.5.13 |
Affected Products
strutsapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.struts:struts2-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.struts:struts2-core to 2.3.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4465 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2016-4465 in your dependencies?
Find it across Maven, including transitive dependencies.