`CHECK` fail in `TensorListScatter` and `TensorListScatterV2` in eager modeGHSA-xf83-q765-xm6m
GHSA-xf83-q765-xm6m is a security vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-cpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Another instance of CVE-2022-35991, where TensorListScatter and TensorListScatterV2 crash via non scalar inputs inelement_shape, was found in eager mode and fixed.
import tensorflow as tf
arg_0=tf.random.uniform(shape=(2, 2, 2), dtype=tf.float16, maxval=None)
arg_1=tf.random.uniform(shape=(2, 2, 2), dtype=tf.int32, maxval=65536)
arg_2=tf.random.uniform(shape=(2, 2, 2), dtype=tf.int32, maxval=65536)
arg_3=''
tf.raw_ops.TensorListScatter(tensor=arg_0, indices=arg_1,
element_shape=arg_2, name=arg_3)
Patches
We have patched the issue in GitHub commit bf9932fc907aff0e9e8cccf769e8b00d30fd81a1.
The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Pattarakrit Rattankul
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.8.4pip install --upgrade 'tensorflow==2.8.4' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow==2.9.3' |
| 🐍PyPI | tensorflow | ≥ 2.10.0&&< 2.10.1 | 2.10.1pip install --upgrade 'tensorflow==2.10.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.8.4pip install --upgrade 'tensorflow-cpu==2.8.4' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.8.4pip install --upgrade 'tensorflow-gpu==2.8.4' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.3 | 2.9.3pip install --upgrade 'tensorflow-cpu==2.9.3' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xf83-q765-xm6m is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-xf83-q765-xm6m in your dependencies?
Find it across PyPI, including transitive dependencies.