Incorrect Default Permissions in SupervisorGHSA-x7c8-4x3h-874w
HIGHGHSA-x7c8-4x3h-874w is a high-severity (CVSS 8.8) Incorrect Default Permissions vulnerability in supervisor. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for supervisor — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
supervisor🐍supervisor🐍supervisor🐍supervisorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | supervisor | all versions | 3.0.1pip install --upgrade 'supervisor==3.0.1' |
| 🐍PyPI | supervisor | ≥ 3.1.0&&< 3.1.4 | 3.1.4pip install --upgrade 'supervisor==3.1.4' |
| 🐍PyPI | supervisor | ≥ 3.2.0&&< 3.2.4 | 3.2.4pip install --upgrade 'supervisor==3.2.4' |
| 🐍PyPI | supervisor | ≥ 3.3.0&&< 3.3.3 | 3.3.3pip install --upgrade 'supervisor==3.3.3' |
Affected Products
debian linuxdebianfedorafedoraprojectcloudformsredhatsupervisorsupervisordResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Supervisor 3.0a1 < 3.3.2 - XML-RPC (Authenticated) Remote Code Execution (Metasploit)
by Metasploit · Sep 25, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for supervisor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update supervisor to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x7c8-4x3h-874w is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
How to detect GHSA-x7c8-4x3h-874w
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-x7c8-4x3h-874w -u https://target- Template
- XML-RPC Server - Remote Code Execution
- Severity
- high
- Impact
- Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the target system.
- Remediation
- Apply the latest security patches or disable the XML-RPC server if not required.
Template by ProjectDiscovery nuclei-templates (notnotnotveg), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.8 | ansible-tower-0:3.1.5-1.el7at | RHSA-2017:3005 |
Frequently Asked Questions
Is GHSA-x7c8-4x3h-874w in your dependencies?
Find it across PyPI, including transitive dependencies.