NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-11610 — supervisor

HIGH

CVE-2017-11610 is a high-severity (CVSS 8.8) Incorrect Default Permissions vulnerability in supervisor. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for supervisor — see the affected versions and patch details below.

Incorrect Default Permissions in Supervisor

Also known asGHSA-x7c8-4x3h-874wPYSEC-2017-41
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
8 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
87.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
85.4%88.9%92.3%95.8%93.8%87.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍supervisor🐍supervisor🐍supervisor🐍supervisor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsupervisorall versions3.0.1pip install --upgrade 'supervisor==3.0.1'
🐍PyPIsupervisor≥ 3.1.0&&< 3.1.43.1.4pip install --upgrade 'supervisor==3.1.4'
🐍PyPIsupervisor≥ 3.2.0&&< 3.2.43.2.4pip install --upgrade 'supervisor==3.2.4'
🐍PyPIsupervisor≥ 3.3.0&&< 3.3.33.3.3pip install --upgrade 'supervisor==3.3.3'

Affected Products

4 products · 18 configurations
OS
debian linuxdebian
2 versions
8.09.0
OS
fedorafedoraproject
3 versions
242526
Application
cloudformsredhat
1 version
4.5
Application
supervisorsupervisord
≤ 3.0
11 versions
3.1.03.1.13.1.23.1.33.2.03.2.13.2.23.2.33.3.03.3.13.3.2
Exploits & PoCs
8

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-42779remotelinux✓ Verified

Supervisor 3.0a1 < 3.3.2 - XML-RPC (Authenticated) Remote Code Execution (Metasploit)

by Metasploit · Sep 25, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for supervisor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update supervisor to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11610 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

How to detect CVE-2017-11610

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2017-11610 -u https://target
Template
XML-RPC Server - Remote Code Execution
Severity
high
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the target system.
Remediation
Apply the latest security patches or disable the XML-RPC server if not required.

Template by ProjectDiscovery nuclei-templates (notnotnotveg), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
CloudForms Management Engine 5.8ansible-tower-0:3.1.5-1.el7atRHSA-2017:3005

Frequently Asked Questions

The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.
O3 Security · Impact-Aware SCA

Is CVE-2017-11610 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-11610: supervisor — Fixed in 3.0.1