Drupal Core Arbitrary PHP code execution vulnerabilityGHSA-x72f-ggjw-v5xh
HIGHGHSA-x72f-ggjw-v5xh is a high-severity (CVSS 8.8) CWE-77 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.8.0&&< 8.8.8 | 8.8.8composer require drupal/core:^8.8.8 |
| 🐘Packagist | drupal/core | ≥ 8.9.0&&< 8.9.1 | 8.9.1composer require drupal/core:^8.9.1 |
| 🐘Packagist | drupal/core | ≥ 9.0.0&&< 9.0.1 | 9.0.1composer require drupal/core:^9.0.1 |
| 🐘Packagist | drupal/drupal | ≥ 8.8.0&&< 8.8.8 | 8.8.8composer require drupal/drupal:^8.8.8 |
| 🐘Packagist | drupal/drupal | ≥ 8.9.0&&< 8.9.1 | 8.9.1composer require drupal/drupal:^8.9.1 |
| 🐘Packagist | drupal/drupal | ≥ 9.0.0&&< 9.0.1 | 9.0.1composer require drupal/drupal:^9.0.1 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.8.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x72f-ggjw-v5xh is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-x72f-ggjw-v5xh in your dependencies?
Find it across Packagist, including transitive dependencies.