NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Regular Expression Denial of Service in semverGHSA-x6fg-f45m-jf5q

HIGHFix: github/advisory-database#7102

GHSA-x6fg-f45m-jf5q is a high-severity (CVSS 7.5) CWE-399 vulnerability in semver. A fix is available for semver — see the affected versions and patch details below.

Also known asCVE-2015-8855
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.00%2.88%5.75%8.63%1.1%6.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

40Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
semvernpm
1146.4Mdownloads / week

Description

Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.

Recommendation

Update to version 4.3.2 or later

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsemver≥ 1.0.4&&< 4.3.24.3.2npm install semver@4.3.2

Affected Products

1 product · 1 configurations
Application
node.jsnodejs
≤ 4.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for semver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update semver to 4.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x6fg-f45m-jf5q is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Versions 4.3.1 and earlier of `semver` are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed. ## Recommendation Update to version 4.3.2 or later
O3 Security · Impact-Aware SCA

Is GHSA-x6fg-f45m-jf5q in your dependencies?

Find it across npm, including transitive dependencies.

Regular Expression Denial of Service in semver (High 7.5)