CVE-2015-8855 is a high-severity (CVSS 7.5) CWE-399 vulnerability in semver. A fix is available for semver — see the affected versions and patch details below.
Regular Expression Denial of Service in semver
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
semvernpmDescription
Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.
Recommendation
Update to version 4.3.2 or later
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | semver | ≥ 1.0.4&&< 4.3.2 | 4.3.2npm install semver@4.3.2 |
Affected Products
node.jsnodejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for semver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update semver to 4.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-8855 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2015-8855 in your dependencies?
Find it across npm, including transitive dependencies.