Silverstripe Missing security check on dev/build/defaultsGHSA-x5w2-wcr8-9q45
MEDIUMFix: silverstripe/silverstripe-framework@15d4db3GHSA-x5w2-wcr8-9q45 is a medium-severity (CVSS 6.5) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The buildDefaults method on DevelopmentAdmin is missing a permission check.
In live mode, if you access /dev/build, you are requested to login first. However, if you access /dev/build/defaults, then the action is performed without any login check. This should be protected in the same way that /dev/build is. The buildDefaults view is requireDefaultRecords() on each DataObject class, and hence has the potential to modify database state. It also lists all modified tables, allowing attackers more insight into which modules are used, and how the database tables are structured.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | all versions | 3.1.17composer require silverstripe/framework:^3.1.17 |
| 🐘Packagist | silverstripe/framework | ≥ 3.2.0&&< 3.2.2 | 3.2.2composer require silverstripe/framework:^3.2.2 |
| 🐘Packagist | silverstripe/framework | ≥ 3.3.0-beta1&&< 3.3.0 | 3.3.0composer require silverstripe/framework:^3.3.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.1.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x5w2-wcr8-9q45 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-x5w2-wcr8-9q45 in your dependencies?
Find it across Packagist, including transitive dependencies.