Ghost: Server-Side Request Forgery Mitigation IssueGHSA-x5mm-wm4g-j5xv
MEDIUMGHSA-x5mm-wm4g-j5xv is a medium-severity (CVSS 4) Server-Side Request Forgery (SSRF) vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-x5mm-wm4g-j5xv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
ghostnpmDescription
Impact
A validation issue allowed some functionality, such as Webmentions, to be abused by an unauthenticated user to make limited HTTP requests to hosts in the Ghost server's internal network. A successful attack would not result in any response data being returned.
Vulnerable versions
This vulnerability is present in Ghost from v6.26.0 up to v6.54.0.
Patches
v6.54.1 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
References
Ghost thanks Hwang Seyeon for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email Ghost at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | ghost | ≥ 6.26.0&&< 6.54.1 | 6.54.1npm install ghost@6.54.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ghost to 6.54.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x5mm-wm4g-j5xv is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-x5mm-wm4g-j5xv in your dependencies?
Find it across npm, including transitive dependencies.