NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

RDF4J vulnerable to zip slipGHSA-x3cr-x949-h5jv

HIGHFix: eclipse/rdf4j#1211

GHSA-x3cr-x949-h5jv is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.eclipse.rdf4j:rdf4j. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.eclipse.rdf4j:rdf4j — see the affected versions and patch details below.

Also known asCVE-2018-20227
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.91%1.38%1.85%2.32%1.4%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.eclipse.rdf4j:rdf4j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

RDF4J prior to 2.5.0 allows Directory Traversal via ../ in an entry in a ZIP archive.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.eclipse.rdf4j:rdf4jall versions2.5.0org.eclipse.rdf4j:rdf4j:2.5.0

Affected Products

1 product · 1 configurations
Application
rdf4jeclipse
< 2.5.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.rdf4j:rdf4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.eclipse.rdf4j:rdf4j to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x3cr-x949-h5jv is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

RDF4J prior to 2.5.0 allows Directory Traversal via ../ in an entry in a ZIP archive.
O3 Security · Impact-Aware SCA

Is GHSA-x3cr-x949-h5jv in your dependencies?

Find it across Maven, including transitive dependencies.

RDF4J vulnerable to zip slip (High 7.5)