Yapscan Denial of Service vulnerability in report serverGHSA-wxwq-525w-hcqx
HIGHFix: fkie-cad/yapscan#46GHSA-wxwq-525w-hcqx is a high-severity (CVSS 7.5) vulnerability in github.com/fkie-cad/yapscan. A fix is available for github.com/fkie-cad/yapscan — see the affected versions and patch details below.
Real-World Exposure
github.com/fkie-cad/yapscanReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If you use the report server, it may be vulnerable to a Denial of Service attack.
Patches
Has been patched in v0.19.2.
References
The vulnerability was inherited by the following upstream vulnerabilites
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/fkie-cad/yapscan | ≥ 0.18.0&&< 0.19.2 | 0.19.2go get github.com/fkie-cad/yapscan@v0.19.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/fkie-cad/yapscan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/fkie-cad/yapscan to 0.19.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wxwq-525w-hcqx is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-wxwq-525w-hcqx in your dependencies?
Find it across Go, including transitive dependencies.