NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Yapscan's report receiver server vulnerable to path traversal and log injectionGHSA-9h6h-9g78-86f7

HIGHFix: fkie-cad/yapscan@a75a20b

GHSA-9h6h-9g78-86f7 is a high-severity (CVSS 7.5) vulnerability in github.com/fkie-cad/yapscan. A fix is available for github.com/fkie-cad/yapscan — see the affected versions and patch details below.

Also known asGO-2022-1204
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Aug 21, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐹github.com/fkie-cad/yapscan

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

If you make use of the report receiver server (experimental), a client may be able to forge requests such that arbitrary files on the host can be overwritten (subject to permissions of the yapscan server), leading to loss of data. This is particularly problematic if you do not authenticate clients and/or run the server with elevated permissions.

Patches

Vulnerable versions:

  • v0.18.0
  • v0.19.0 (unreleased)

This problem is patched in version v0.19.1

Workarounds

Update to the newer version is highly encouraged!

Measures to reduce the risk of this include authenticating clients (see --client-ca flag) and containerization of the yapscan server.

References

The tracking issue is #35. There you can find the commits, fixing the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/fkie-cad/yapscan≥ 0.18.0&&< 0.19.10.19.1go get github.com/fkie-cad/yapscan@v0.19.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/fkie-cad/yapscan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/fkie-cad/yapscan to 0.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9h6h-9g78-86f7 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact If you make use of the **report receiver server** (experimental), a client may be able to forge requests such that arbitrary files on the host can be overwritten (subject to permissions of the yapscan server), leading to loss of data. This is particularly problematic if you do not authenticate clients and/or run the server with elevated permissions. ### Patches Vulnerable versions: - v0.18.0 - v0.19.0 (unreleased) This problem is patched in version v0.19.1 ### Workarounds Update to the newer version is highly encouraged! Measures to reduce the risk of this include authentica
O3 Security · Impact-Aware SCA

Is GHSA-9h6h-9g78-86f7 in your dependencies?

Find it across Go, including transitive dependencies.

Yapscan's report receiver server vulnerable to path…