GHSA-wg4r-q74r-p7c8 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in showdoc/showdoc. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for showdoc/showdoc — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
showdoc/showdocReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
ShowDoc is vulnerable to stored cross-site scripting due to unrestricted file upload in versions 2.10.3 and prior. A patch is available and anticipated to be part of version 2.10.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | showdoc/showdoc | all versions | 2.10.4composer require showdoc/showdoc:^2.10.4 |
Affected Products
showdocshowdocResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for showdoc/showdoc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update showdoc/showdoc to 2.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wg4r-q74r-p7c8 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-wg4r-q74r-p7c8 in your dependencies?
Find it across Packagist, including transitive dependencies.