NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-0941 — showdoc

HIGHFix: star7th/showdoc@4b6e660

CVE-2022-0941 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in showdoc/showdoc. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for showdoc/showdoc — see the affected versions and patch details below.

Stored XSS due to Unrestricted File Upload in star7th/showdoc

Also known asGHSA-wg4r-q74r-p7c8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘showdoc/showdoc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

ShowDoc is vulnerable to stored cross-site scripting due to unrestricted file upload in versions 2.10.3 and prior. A patch is available and anticipated to be part of version 2.10.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistshowdoc/showdocall versions2.10.4composer require showdoc/showdoc:^2.10.4

Affected Products

1 product · 1 configurations
Application
showdocshowdoc
≤ 2.10.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for showdoc/showdoc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update showdoc/showdoc to 2.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0941 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

ShowDoc is vulnerable to stored cross-site scripting due to unrestricted file upload in versions 2.10.3 and prior. A patch is available and anticipated to be part of version 2.10.4.
O3 Security · Impact-Aware SCA

Is CVE-2022-0941 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0941: showdoc XSS — Fixed in 2.10.4