NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

Crossplane: Signature verification TOCTOU allows installing unverified package content via mutable tagGHSA-wfqx-gjrf-g28r

CRITICAL

GHSA-wfqx-gjrf-g28r is a critical-severity (CVSS 9) vulnerability in github.com/crossplane/crossplane/v2. A fix is available for github.com/crossplane/crossplane/v2 — see the affected versions and patch details below.

Also known asGO-2026-5709
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
None indexed
Exploitation data as of Sep 29, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐹github.com/crossplane/crossplane/v2🐹github.com/crossplane/crossplane/v2🐹github.com/crossplane/crossplane

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Crossplane allows package signature verification to be configured via the ImageConfig mechanism. When enabled, the package manager uses cosign to verify that packages are correctly signed before pulling and installing them.

When a package is installed using a tag reference (e.g., a semantic version), a malicious OCI registry could serve a correctly signed image for verification, then subsequently serve an unsigned image for installation. This is possible because Crossplane resolves the tag reference separately for each step.

This vulnerability is relevant only for users who do all three of the following:

  1. Configure signature verification for packages,
  2. Install packages using tag references rather than digests, and
  3. Install packages from registries they do not control.

Mitigation

Installing packages by image digest rather than using tags avoids this issue.

Fix

The package manager has been updated to resolve tag references once and use the resulting digest for both signature verification and image fetching. This ensures that Crossplane pulls the same content that had its signature verified. The fix has been applied to Crossplane's main branch and backported to the v2.3 and v2.2 release branches; it will be released in v2.3.3 and v2.2.3.

Note on Fixed Versions

The Crossplane maintainers are not planning to backport the fix for this advisory to the 1.20 branch, for two reasons:

  1. The advisory is relevant only when an alpha feature is enabled and configured, and has a reasonable mitigation that is already a security best practice.
  2. Doing so would require a major refactor of package manager internals to match the refactor that shipped in Crossplane v2.2. Such a refactor would be an unnecessary risk given the policy that v1.20 receives only critical fixes and that this advisory affects only users of an alpha feature.

Credits

This issue was reported, independently, by @bugbunny-research and @tonghuaroot.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/crossplane/crossplane/v2≥ 2.3.0-rc.0&&< 2.3.32.3.3go get github.com/crossplane/crossplane/v2@v2.3.3
🐹Gogithub.com/crossplane/crossplane/v2all versions2.2.3go get github.com/crossplane/crossplane/v2@v2.2.3
🐹Gogithub.com/crossplane/crossplaneall versionsNo fix

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/crossplane/crossplane/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/crossplane/crossplane/v2 to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wfqx-gjrf-g28r is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Summary Crossplane allows package signature verification to be configured via the `ImageConfig` mechanism. When enabled, the package manager uses cosign to verify that packages are correctly signed before pulling and installing them. When a package is installed using a tag reference (e.g., a semantic version), a malicious OCI registry could serve a correctly signed image for verification, then subsequently serve an unsigned image for installation. This is possible because Crossplane resolves the tag reference separately for each step. This vulnerability is relevant only for users who do
O3 Security · Impact-Aware SCA

Is GHSA-wfqx-gjrf-g28r in your dependencies?

Find it across Go, including transitive dependencies.

Crossplane: Signature verification TOCTOU allows…