CVE-2023-37900 — crossplane
LOWCVE-2023-37900 is a low-severity (CVSS 3.4) Uncontrolled Resource Consumption vulnerability in github.com/crossplane/crossplane. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/crossplane/crossplane — see the affected versions and patch details below.
Crossplane vulnerable to denial of service from large image
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37900.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/crossplane/crossplane🐹github.com/crossplane/crossplaneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled.
The impact is low due to the high privileges required to be able to create the Package and the eventually consistency nature of controller.
Patches
The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0, all the supported versions of Crossplane at the time of writing.
Workarounds
Only using images from trusted sources and keeping Package editing/creating privileges to administrators only, which should be both considered already best practices.
References
See ADA-XP-23-16 in the Security Audit's report.
Credits
This was reported as ADA-XP-23-16 by @AdamKorcz and @DavidKorczynski from Ada Logic and facilitated by OSTIF as part of the Security Audit sponsored by CNCF.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/crossplane/crossplane | all versions | 1.11.5go get github.com/crossplane/crossplane@v1.11.5 |
| 🐹Go | github.com/crossplane/crossplane | ≥ 1.12.0&&< 1.12.3 | 1.12.3go get github.com/crossplane/crossplane@v1.12.3 |
Affected Products
crossplanecncfResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/crossplane/crossplane, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/crossplane/crossplane to 1.11.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37900 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2023-37900 in your dependencies?
Find it across Go, including transitive dependencies.