NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

MantisBT vulnerable to XSS via unescaped output in browser_search_plugin.phpGHSA-wfg2-2wmw-6894

MEDIUM

GHSA-wfg2-2wmw-6894 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mantisbt/mantisbt. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

Also known asCVE-2022-28508
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
3 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.29%2.36%4.42%6.49%1.5%5.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An XSS issue was discovered in browser_search_plugin.php in MantisBT up to and including 2.25.2. Unescaped output of the return parameter allows an attacker to inject code into a hidden input field.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbtall versionsNo fix

Affected Products

1 product · 1 configurations
Application
mantisbtmantisbt
< 2.25.2
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of mantisbt/mantisbt for GHSA-wfg2-2wmw-6894. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect GHSA-wfg2-2wmw-6894

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-wfg2-2wmw-6894 -u https://target
Template
MantisBT < 2.25.2 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation allows attackers to execute arbitrary JavaScript code in the context of a victim's browser,potentially leading to session hijacking, credential theft, or phishing attacks.
Remediation
Upgrade to MantisBT version 2.25.2 or later which contains the fix for this vulnerability.If upgrading is not immediately possible, restrict access to the browser_search_plugin.php endpoint.

Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An XSS issue was discovered in browser_search_plugin.php in MantisBT up to and including 2.25.2. Unescaped output of the return parameter allows an attacker to inject code into a hidden input field.
O3 Security · Impact-Aware SCA

Is GHSA-wfg2-2wmw-6894 in your dependencies?

Find it across Packagist, including transitive dependencies.

MantisBT vulnerable to XSS via unescaped output in…