NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-49280 — mantisbt

Fix: mantisbt/mantisbt@2d3a553

CVE-2026-49280 is a security vulnerability in mantisbt/mantisbt. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

MantisBT: REST API unauthorized Issue status change

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Jul 15, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A MantisBT user having $g_update_bug_threshold (UPDATER by default) can change an Issue's Status via REST and SOAP API, even if the $g_set_status_threshold config is set to a higher level (DEVELOPER by default).

Impact

Unauthorized change in Issue workflow.

Patches

https://github.com/mantisbt/mantisbt/releases/tag/release-2.28.4

Workarounds

None

Resources

Credits

Mamdouh Mahfouz (@mamdouhmahfouz)

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbt≥ 2.8.0&&< 2.28.42.28.4composer require mantisbt/mantisbt:^2.28.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 2.28.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49280 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A MantisBT user having *$g_update_bug_threshold* (UPDATER by default) can change an Issue's Status via REST and SOAP API, even if the *$g_set_status_threshold* config is set to a higher level (DEVELOPER by default). ### Impact Unauthorized change in Issue workflow. ### Patches https://github.com/mantisbt/mantisbt/releases/tag/release-2.28.4 ### Workarounds None ### Resources - https://mantisbt.org/bugs/view.php?id=37181 ### Credits Mamdouh Mahfouz (@mamdouhmahfouz)
O3 Security · Impact-Aware SCA

Is CVE-2026-49280 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-49280: mantisbt — Fixed in 2.28.4