PrestaShop has a stored XSS executable in customer service viewGHSA-w9f3-qc75-qgx9
CRITICALGHSA-w9f3-qc75-qgx9 is a critical-severity (CVSS 9.3) Cross-site Scripting (XSS) vulnerability in prestashop/prestashop. A fix is available for prestashop/prestashop — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-w9f3-qc75-qgx9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
prestashop/prestashop🐘prestashop/prestashopReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This is a stored Cross-site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view.
An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover.
Patches
Patched in PrestaShop 8.2.6 and 9.1.1.
Workarounds
None.
Resources
- Reported by Savio at Doyensec (
[email protected]) in collaboration with Anthropic Research.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | prestashop/prestashop | all versions | 8.2.6composer require prestashop/prestashop:^8.2.6 |
| 🐘Packagist | prestashop/prestashop | ≥ 9.0.0&&< 9.1.1 | 9.1.1composer require prestashop/prestashop:^9.1.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/prestashop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update prestashop/prestashop to 8.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w9f3-qc75-qgx9 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-w9f3-qc75-qgx9 in your dependencies?
Find it across Packagist, including transitive dependencies.