CVE-2026-33674 — prestashop
LOWCVE-2026-33674 is a low-severity (CVSS 2) CWE-1173 vulnerability in prestashop/prestashop. A fix is available for prestashop/prestashop — see the affected versions and patch details below.
PrestaShop: Improper Use of Validation Framework
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33674.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
prestashop/prestashop🐘prestashop/prestashopReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | prestashop/prestashop | all versions | 8.2.5composer require prestashop/prestashop:^8.2.5 |
| 🐘Packagist | prestashop/prestashop | ≥ 9.0.0-alpha.1&&< 9.1.0 | 9.1.0composer require prestashop/prestashop:^9.1.0 |
Affected Products
prestashopprestashopDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/prestashop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update prestashop/prestashop to 8.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33674 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-33674 in your dependencies?
Find it across Packagist, including transitive dependencies.