NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Denial of service in GJSONGHSA-w942-gw6m-p62c

HIGHFix: tidwall/gjson@f0ee9eb

GHSA-w942-gw6m-p62c is a high-severity (CVSS 7.5) vulnerability in github.com/tidwall/gjson. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/tidwall/gjson — see the affected versions and patch details below.

Also known asCVE-2020-35380GO-2021-0059
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk-0.22%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.73%1.46%2.18%0.5%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/tidwall/gjson

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

GJSON before 1.6.4 allows attackers to cause a denial of service via crafted JSON. Due to improper bounds checking, maliciously crafted JSON objects can cause an out-of-bounds panic. If parsing user input, this may be used as a denial of service vector.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/tidwall/gjsonall versions1.6.4go get github.com/tidwall/gjson@v1.6.4

Affected Products

1 product · 1 configurations
Application
gjsongjson_project
< 1.6.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/tidwall/gjson, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/tidwall/gjson to 1.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w942-gw6m-p62c is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

GJSON before 1.6.4 allows attackers to cause a denial of service via crafted JSON. Due to improper bounds checking, maliciously crafted JSON objects can cause an out-of-bounds panic. If parsing user input, this may be used as a denial of service vector.
O3 Security · Impact-Aware SCA

Is GHSA-w942-gw6m-p62c in your dependencies?

Find it across Go, including transitive dependencies.

Denial of service in GJSON (High 7.5)