CVE-2020-36067 is a high-severity (CVSS 7.5) CWE-129 vulnerability in github.com/tidwall/gjson. A fix is available for github.com/tidwall/gjson — see the affected versions and patch details below.
Improper Validation of Array Index in GJSON
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/tidwall/gjsonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/tidwall/gjson | all versions | 1.6.6go get github.com/tidwall/gjson@v1.6.6 |
Affected Products
gjsongjson_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/tidwall/gjson, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/tidwall/gjson to 1.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36067 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2020-36067 in your dependencies?
Find it across Go, including transitive dependencies.