wildfly-core allows user with access to management interface to access vault expression, retrieve item from vaultGHSA-w88m-2936-rmxr
LOWFix: wildfly/wildfly-core#4668GHSA-w88m-2936-rmxr is a low-severity (CVSS 3.3) Information Exposure vulnerability in org.wildfly.core:wildfly-server. A fix is available for org.wildfly.core:wildfly-server — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.wildfly.core:wildfly-server☕org.wildfly.core:wildfly-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in wildfly-core in all versions. If a vault expression is in the form of a single attribute that contains multiple expressions, a user who was granted access to the management interface can potentially access a vault expression they should not be able to access and possibly retrieve the item which was stored in the vault. The highest threat from this vulnerability is data confidentiality and integrity.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.wildfly.core:wildfly-server | all versions | 16.0.1.Finalorg.wildfly.core:wildfly-server:16.0.1.Final |
| ☕Maven | org.wildfly.core:wildfly-server | ≥ 17.0.0.Beta2&&< 17.0.0.Beta3 | 17.0.0.Beta3org.wildfly.core:wildfly-server:17.0.0.Beta3 |
Affected Products
descision managerredhatwildflyredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.core:wildfly-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.wildfly.core:wildfly-server to 16.0.1.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w88m-2936-rmxr is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat CodeReady Studio 12 is not affected by this flaw as it does not ship the vulnerable component of wildfly.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 7.3.9 release | wildfly-core | RHSA-2021:3471 |
| Red Hat EAP-XP 2.0.0 via EAP 7.3.x base | wildfly-core | RHSA-2021:3516 |
| Red Hat Fuse 7.11 | wildfly-core | RHSA-2022:5532 |
| Red Hat JBoss Enterprise Application Platform | org.wildfly.core/wildfly-controller:15.0.4.Final-redhat-00001 | RHSA-2021:3660 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el6eap | RHSA-2021:3466 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el7eap | RHSA-2021:3467 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8 | eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el8eap | RHSA-2021:3468 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-wildfly-0:7.4.1-2.GA_redhat_00003.1.el8eap | RHSA-2021:3658 |
Frequently Asked Questions
Is GHSA-w88m-2936-rmxr in your dependencies?
Find it across Maven, including transitive dependencies.