NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-10862 — wildfly-server

MEDIUM

CVE-2018-10862 is a medium-severity (CVSS 5.5) Path Traversal vulnerability in org.wildfly.core:wildfly-server. A fix is available for org.wildfly.core:wildfly-server — see the affected versions and patch details below.

Improper Limitation of a Pathname to a Restricted Directory in WildFly

Also known asGHSA-w8r2-5j8x-x8j6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.17%1.76%0.3%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.wildfly.core:wildfly-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

WildFly Core before version 6.0.0.Alpha3 does not properly validate file paths in .war archives, allowing for the extraction of crafted .war archives to overwrite arbitrary files. This is an instance of the 'Zip Slip' vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.wildfly.core:wildfly-serverall versions6.0.0.Alpha3org.wildfly.core:wildfly-server:6.0.0.Alpha3

Affected Products

3 products · 6 configurations
Application
jboss enterprise application platformredhat
1 version
7.1.0
Application
virtualizationredhat
1 version
4.0
Application
wildfly coreredhat
≤ 5.0.0
1 version
6.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.core:wildfly-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.wildfly.core:wildfly-server to 6.0.0.Alpha3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10862 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability can only be exploited by users with deployment permissions.

ProductFixed inAdvisory
Red Hat Data Grid 7.3.6wildflyRHSA-2020:2321
Red Hat JBoss EAP 7.1see advisoryRHSA-2018:2277
Red Hat JBoss EAP 7.1wildflyRHSA-2018:2425
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-apache-cxf-0:3.1.16-1.redhat_1.1.ep7.el6RHSA-2018:2276
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-activemq-artemis-0:1.5.5.013-1.redhat_1.1.ep7.el6RHSA-2018:2423
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7eap7-activemq-artemis-0:1.5.5.013-1.redhat_1.1.ep7.el7RHSA-2018:2424
Red Hat JBoss Enterprise Application Platform Continuous DeliverywildflyRHSA-2020:2562
Red Hat Single Sign-On 7.2wildflyRHSA-2018:2279

Frequently Asked Questions

WildFly Core before version 6.0.0.Alpha3 does not properly validate file paths in .war archives, allowing for the extraction of crafted .war archives to overwrite arbitrary files. This is an instance of the 'Zip Slip' vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2018-10862 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-10862: wildfly-server — Fixed in 6.0.0.Alpha3