Apache Answer has an Exposure of Private Personal Information to an Unauthorized Actor vulnerabilityGHSA-w754-5646-xq9j
MEDIUMFix: apache/answer@92994b4GHSA-w754-5646-xq9j is a medium-severity (CVSS 6.1) CWE-359 vulnerability in github.com/apache/incubator-answer. A fix is available for github.com/apache/incubator-answer — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-w754-5646-xq9j.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/apache/incubator-answerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Exposure of Private Personal Information to an Unauthorized Actor vulnerability in Apache Answer.
This issue affects Apache Answer: through 2.0.0.
Timeline-related APIs lacked proper authorization checks, allowing regular authenticated users to access deleted, private, or unapproved content and its revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/apache/incubator-answer | all versions | 1.7.2-0.20260206073245-92994b49976bgo get github.com/apache/incubator-answer@v1.7.2-0.20260206073245-92994b49976b |
Affected Products
answerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/apache/incubator-answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/apache/incubator-answer to 1.7.2-0.20260206073245-92994b49976b or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w754-5646-xq9j is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-w754-5646-xq9j in your dependencies?
Find it across Go, including transitive dependencies.