NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2026-34905 — incubator-answer

MEDIUMFix: apache/answer@11c8038

CVE-2026-34905 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in github.com/apache/incubator-answer. A fix is available for github.com/apache/incubator-answer — see the affected versions and patch details below.

Apache Answer: Unlisted Questions Accessible via Direct API Access

Also known asGHSA-85r2-pvg8-89r9GO-2026-6152
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-34905.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.20%
Lower risk than most CVEs24th percentile — riskier than 24% of all scored CVEsHighest risk
0.00%0.34%0.68%1.01%0.3%0.3%0.3%0.5%0.3%Jul 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/apache/incubator-answer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.0.

The unlisted question feature did not enforce access restrictions on direct API endpoints, allowing authenticated users to discover and access unlisted questions, their answers, comments, and revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/apache/incubator-answerall versions1.7.2-0.20260509071350-11c80384f13ago get github.com/apache/incubator-answer@v1.7.2-0.20260509071350-11c80384f13a

Affected Products

1 product · 1 configurations
Application
answerapache
< 2.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/apache/incubator-answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/apache/incubator-answer to 1.7.2-0.20260509071350-11c80384f13a or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-34905 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. The unlisted question feature did not enforce access restrictions on direct API endpoints, allowing authenticated users to discover and access unlisted questions, their answers, comments, and revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-34905 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-34905: incubator-answer — Fix Available