Apache Answer has an Exposure of Sensitive Information to an Unauthorized Actor vulnerabilityGHSA-85r2-pvg8-89r9
MEDIUMFix: apache/answer@11c8038GHSA-85r2-pvg8-89r9 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in github.com/apache/incubator-answer. A fix is available for github.com/apache/incubator-answer — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-85r2-pvg8-89r9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/apache/incubator-answerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Answer.
This issue affects Apache Answer: through 2.0.0.
The unlisted question feature did not enforce access restrictions on direct API endpoints, allowing authenticated users to discover and access unlisted questions, their answers, comments, and revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/apache/incubator-answer | all versions | 1.7.2-0.20260509071350-11c80384f13ago get github.com/apache/incubator-answer@v1.7.2-0.20260509071350-11c80384f13a |
Affected Products
answerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/apache/incubator-answer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/apache/incubator-answer to 1.7.2-0.20260509071350-11c80384f13a or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-85r2-pvg8-89r9 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-85r2-pvg8-89r9 in your dependencies?
Find it across Go, including transitive dependencies.