NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
LOW severity

ImageMagick has a heap-buffer-overflow in FTXT encoderGHSA-w54j-7wpm-crhj

LOW

GHSA-w54j-7wpm-crhj is a low-severity (CVSS 3.3) Out-of-bounds Read vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

Also known asCVE-2026-56374
Published
Updated
Affected
18 pkgs
Patched
18 / 18
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-w54j-7wpm-crhj.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.07%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.2%0.2%Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

18 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64.NETMagick.NET-Q16-OpenMP-x64+10 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

The FTXT encoder lacks a boundary check when parsing ftxt:format, resulting in an out of bounds read.

==3040863==ERROR: AddressSanitizer: heap-buffer-overflow on address 0x5020000085b2 at pc 0x606c1ee0c6ce bp 0x7ffee30d6150 sp 0x7ffee30d6148
READ of size 1 at 0x5020000085b2 thread T0

Affected Packages

18 total 18 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.12.0dotnet add package Magick.NET-Q16-AnyCPU --version 14.12.0
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.12.0dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.12.0
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.12.0dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.12.0
.NETNuGetMagick.NET-Q16-HDRI-arm64all versions14.12.0dotnet add package Magick.NET-Q16-HDRI-arm64 --version 14.12.0
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.12.0dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.12.0
.NETNuGetMagick.NET-Q16-HDRI-x86all versions14.12.0dotnet add package Magick.NET-Q16-HDRI-x86 --version 14.12.0

Affected Products

1 product · 1 configurations
Application
imagemagickimagemagick
< 7.1.2-19
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w54j-7wpm-crhj is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This low-impact heap buffer overflow in ImageMagick's FTXT encoder, caused by insufficient boundary checks, could lead to denial of service or information disclosure if a user opens a specially crafted FTXT file.

Workaround published by Red Hat
To mitigate this, disable the vulnerable FTXT format by adding the following line to your ImageMagick security policy file (typically /etc/ImageMagick-7/policy.xml): <policy domain="coder" rights="none" pattern="FTXT" /> Applying this mitigation will immediately block ImageMagick from processing any files in the FTXT format, but requires no service restarts or downtime.
Source: Red Hat security advisory for GHSA-w54j-7wpm-crhj (CC BY 4.0)

Frequently Asked Questions

The FTXT encoder lacks a boundary check when parsing `ftxt:format`, resulting in an out of bounds read. ``` ==3040863==ERROR: AddressSanitizer: heap-buffer-overflow on address 0x5020000085b2 at pc 0x606c1ee0c6ce bp 0x7ffee30d6150 sp 0x7ffee30d6148 READ of size 1 at 0x5020000085b2 thread T0 ```
O3 Security · Impact-Aware SCA

Is GHSA-w54j-7wpm-crhj in your dependencies?

Find it across NuGet, including transitive dependencies.

ImageMagick has a heap-buffer-overflow in FTXT encoder