Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
LOW severity

ImageMagick: Heap Buffer Over-Write in X11 import with crafted window titleGHSA-76q6-2p6h-xjqr

LOW

GHSA-76q6-2p6h-xjqr is a low-severity (CVSS 1.8) CWE-122 vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

Also known asCVE-2026-61464
Published
Updated
Affected
17 pkgs
Patched
17 / 17
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-76q6-2p6h-xjqr.

EPSS Exploitation Probability

via FIRST.org ↗
0.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs0th percentile — riskier than 0% of all scored CVEsHighest risk
0.00%0.20%0.39%0.59%0.1%0.1%0.1%Sep 26Oct 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

GHSA-76q6-2p6h-xjqr by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

17 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64.NETMagick.NET-Q16-OpenMP-x64.NETMagick.NET-Q16-arm64+9 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ImageMagick before 7.1.2-26 and 6.9.13-51 contains a heap-based buffer over-write vulnerability that occurs when running an X11 import with a crafted window title, which can result in heap memory corruption and denial of service.

Affected Packages

17 total 17 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.15.0dotnet add package Magick.NET-Q16-AnyCPU --version 14.15.0
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.15.0dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.15.0
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.15.0dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.15.0
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.15.0dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.15.0
.NETNuGetMagick.NET-Q16-HDRI-x86all versions14.15.0dotnet add package Magick.NET-Q16-HDRI-x86 --version 14.15.0
.NETNuGetMagick.NET-Q16-OpenMP-arm64all versions14.15.0dotnet add package Magick.NET-Q16-OpenMP-arm64 --version 14.15.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.15.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-76q6-2p6h-xjqr is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat Enterprise Linux ships ImageMagick in RHEL 6 ELS and RHEL 7 ELS. This flaw has been rated as having a Low security impact and is not currently planned to be addressed in future updates of those products. For additional information, refer to the Issue Severity Classification:…

Workaround published by Red Hat
Do not use ImageMagick's X11 import command with untrusted window titles. The X11 import functionality requires a running X11 display and is not typically used in server-side image processing pipelines. Upgrade to ImageMagick 7.1.2-26 or 6.9.13-51 mitigates the issue.
Source: Red Hat security advisory for GHSA-76q6-2p6h-xjqr (CC BY 4.0)

Frequently Asked Questions

Running an X11 import with a crafted window title can result in a heap buffer over-write.
O3 Security · Impact-Aware SCA

Is GHSA-76q6-2p6h-xjqr in your dependencies?

Find it across NuGet, including transitive dependencies.

ImageMagick: Heap Buffer Over-Write in X11 import with…