GHSA-w4pj-7p68-3vgv is a low-severity (CVSS 3.5) Cross-site Scripting (XSS) vulnerability in october/backend. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for october/backend — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/backendReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user with access to a markdown FormWidget that stores data persistently could create a stored XSS attack against themselves and any other users with access to the generated HTML from the field.
Patches
Issue has been patched in Build 466 (v1.0.466) & RainLab.Blog v1.4.1 by restricting the ability to store JS in markdown to only users that have been explicitly granted the backend.allow_unsafe_markdown permission.
Workarounds
Apply https://github.com/octobercms/october/commit/9ecfb4867baae14a0d3f99f5b5c1e8a979ae8746 & https://github.com/rainlab/blog-plugin/commit/6ae19a6e16ef3ba730692bc899851342c858bb94 to your installation manually if unable to upgrade to Build 466 or v1.4.1 of RainLab.Blog (if using that plugin).
References
Reported by Sivanesh Ashok
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Threat assessment:
<img width="1100" alt="Screen Shot 2020-03-31 at 2 01 52 PM" src="https://user-images.githubusercontent.com/7253840/78070158-8f7ef580-7358-11ea-950c-226533f6a0a3.png">Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/backend | ≥ 1.0.319&&< 1.0.466 | 1.0.466composer require october/backend:^1.0.466 |
Affected Products
octoberoctobercmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/backend to 1.0.466 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w4pj-7p68-3vgv is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-w4pj-7p68-3vgv in your dependencies?
Find it across Packagist, including transitive dependencies.