GHSA-w29m-fjp4-qhmq is a high-severity (CVSS 7.7) CWE-99 vulnerability in org.opencastproject:base. A fix is available for org.opencastproject:base — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opencastproject:base☕org.opencastproject:baseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Opencast allows almost arbitrary identifiers for media packages and elements to be used. This can be problematic for operation and security since such identifiers are sometimes used for file system operations which may lead to an attacker being able to escape working directories and write files to other locations.
In addition, Opencast's Id.toString(…) vs Id.compact(…) behavior, the latter trying to mitigate some of the file system problems, can cause errors due to identifier mismatch since an identifier may unintentionally change.
Patches
This issue is fixed in Opencast 7.6 and 8.1.
Workarounds
There is no workaround for this.
For more information
If you have any questions or comments about this advisory:
- Open an issue in opencast/opencast
- For security-relevant information, email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opencastproject:base | all versions | 7.6org.opencastproject:base:7.6 |
| ☕Maven | org.opencastproject:base | ≥ 8.0&&< 8.1 | 8.1org.opencastproject:base:8.1 |
Affected Products
opencastapereoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opencastproject:base, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opencastproject:base to 7.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w29m-fjp4-qhmq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-w29m-fjp4-qhmq in your dependencies?
Find it across Maven, including transitive dependencies.