CVE-2017-1000217 is a high-severity (CVSS 8.8) CWE-74 vulnerability in org.opencastproject:base. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.opencastproject:base — see the affected versions and patch details below.
Opencast RCE Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opencastproject:baseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opencastproject:base | all versions | 2.3.3org.opencastproject:base:2.3.3 |
Affected Products
opencastopencastResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opencastproject:base, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opencastproject:base to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000217 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-1000217 in your dependencies?
Find it across Maven, including transitive dependencies.