GHSA-vx9g-377x-xwxq is a critical-severity (CVSS 9.8) Server-Side Request Forgery (SSRF) vulnerability in gibbon. A fix is available for gibbon — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
gibbonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Gibbon v3.4.3 and below allows attackers to execute a Server-Side Request Forgery (SSRF) via a crafted URL. This issue has been resolved in version 3.4.4
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | gibbon | all versions | 3.4.4bundle update gibbon --conservative |
Affected Products
gibbongibbon_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gibbon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gibbon to 3.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vx9g-377x-xwxq is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-vx9g-377x-xwxq in your dependencies?
Find it across RubyGems, including transitive dependencies.