NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Cross-site scripting in BleachGHSA-vv2x-vrpj-qqpq

MEDIUMFix: mozilla/bleach@79b7a3c

GHSA-vv2x-vrpj-qqpq is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in bleach. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for bleach — see the affected versions and patch details below.

Also known asCVE-2021-23980PYSEC-2021-865
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-vv2x-vrpj-qqpq.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.5%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍bleach

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A mutation XSS affects users calling bleach.clean with all of:

  • svg or math in the allowed tags
  • p or br in allowed tags
  • style, title, noscript, script, textarea, noframes, iframe, or xmp in allowed tags
  • the keyword argument strip_comments=False

Note: none of the above tags are in the default allowed tags and strip_comments defaults to True.

Patches

Users are encouraged to upgrade to bleach v3.3.0 or greater.

Note: bleach v3.3.0 introduces a breaking change to escape HTML comments by default.

Workarounds

  • modify bleach.clean calls to at least one of:

    • not allow the style, title, noscript, script, textarea, noframes, iframe, or xmp tag
    • not allow svg or math tags
    • not allow p or br tags
    • set strip_comments=True
  • A strong Content-Security-Policy without unsafe-inline and unsafe-eval script-srcs) will also help mitigate the risk.

References

Credits

  • Reported by Yaniv Nizry from the CxSCA AppSec group at Checkmarx
  • Additional eject tags not mentioned in the original advisory and the CSP mitigation line being truncated in the revised advisory reported by Michał Bentkowski at Securitum

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIbleachall versions3.3.0pip install --upgrade 'bleach==3.3.0'

Affected Products

1 product · 1 configurations
Application
bleachmozilla
< 3.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bleach, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bleach to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vv2x-vrpj-qqpq is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Automation Hub 4.2 for RHEL 7automation-hub-0:4.2.2-1.el7pcRHSA-2021:0781
UbuntuMEDIUM

Frequently Asked Questions

### Impact A [mutation XSS](https://cure53.de/fp170.pdf) affects users calling `bleach.clean` with all of: * `svg` or `math` in the allowed tags * `p` or `br` in allowed tags * `style`, `title`, `noscript`, `script`, `textarea`, `noframes`, `iframe`, or `xmp` in allowed tags * the keyword argument `strip_comments=False` Note: none of the above tags ar
O3 Security · Impact-Aware SCA

Is GHSA-vv2x-vrpj-qqpq in your dependencies?

Find it across PyPI, including transitive dependencies.

Cross-site scripting in Bleach (Medium 6.1)