Information Disclosure in TYPO3 BackendGHSA-vpr3-rc99-2wpr
MEDIUMGHSA-vpr3-rc99-2wpr is a medium-severity (CVSS 5.3) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The TYPO3 backend module stores the username of an authenticated backend user in its cache files. By guessing the file path to the cache files it is possible to receive valid backend usernames.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.26 | 6.2.26composer require typo3/cms:^6.2.26 |
| 🐘Packagist | typo3/cms | ≥ 7.6.0&&< 7.6.10 | 7.6.10composer require typo3/cms:^7.6.10 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.2.1 | 8.2.1composer require typo3/cms:^8.2.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 6.2.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vpr3-rc99-2wpr is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-vpr3-rc99-2wpr in your dependencies?
Find it across Packagist, including transitive dependencies.