NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀 crates.io🐹 Go
Not in CISA KEV

Panic in wasmvm can slow down block productionGHSA-vmqh-5232-v43r

Fix: CosmWasm/cosmwasm@108e7dc

GHSA-vmqh-5232-v43r is a security vulnerability in cosmwasm-vm. A fix is available for cosmwasm-vm — see the affected versions and patch details below.

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Dec 10, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

6 pkgs affected
🦀cosmwasm-vm🦀cosmwasm-vm🦀cosmwasm-vm🐹github.com/CosmWasm/wasmvm/v2🐹github.com/CosmWasm/wasmvm/v2🐹github.com/CosmWasm/wasmvm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

CWA-2024-008

Severity

Medium (Moderate + Likely)1

Affected versions:

  • wasmvm >= 2.1.0, < 2.1.3
  • wasmvm >= 2.0.0, < 2.0.4
  • wasmvm < 1.5.5
  • cosmwasm-vm >= 2.1.0, < 2.1.4
  • cosmwasm-vm >= 2.0.0, < 2.0.7
  • cosmwasm-vm < 1.5.8

Patched versions:

  • wasmvm 1.5.5, 2.0.4, 2.1.3
  • cosmwasm-vm 1.5.8, 2.0.7, 2.1.4

Description of the bug

(Blank for now. We'll add more detail once chains had a chance to upgrade.)

Patch

Applying the patch

The patch will be shipped in releases of wasmvm. You can update more or less as follows:

  1. Check the current wasmvm version: go list -m github.com/CosmWasm/wasmvm
  2. Bump the github.com/CosmWasm/wasmvm dependency in your go.mod to 1.5.5, 2.0.4, 2.1.3 depending on which minor version you are; go mod tidy; commit.
  3. If you use the static libraries libwasmvm_muslc.aarch64.a/libwasmvm_muslc.x86_64.a, update them accordingly.
  4. Check the updated wasmvm version: go list -m github.com/CosmWasm/wasmvm and ensure you see 1.5.5, 2.0.4, 2.1.3.
  5. Follow your regular practices to deploy chain upgrades.

To double check if the correct library version is loaded at runtime, use this query: <appd> query wasm libwasmvm-version. It must show 1.5.5, 2.0.4 or 2.1.3.

The patch is consensus breaking and requires a coordinated upgrade.

Acknowledgement

This issue was found by meadow101 who reported it to the Cosmos Bug Bounty Program on HackerOne.

If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.

Timeline

  • 2024-08-22: Confio receives a report through the Cosmos bug bounty program maintained by Amulet.
  • 2024-08-23: Confio security contributors confirm the report.
  • 2024-09-09: Confio developed the patch internally.
  • 2024-09-23: Patch is released.

Footnotes

  1. following Amulet's Severity Classification Framework ACMv1: https://github.com/interchainio/security/blob/e0227a1fb4059144aab4f6003eeee7f09912db3a/resources/CLASSIFICATION_MATRIX.md ↩

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iocosmwasm-vm≥ 2.1.0&&< 2.1.42.1.4cargo update -p cosmwasm-vm --precise 2.1.4
🦀crates.iocosmwasm-vm≥ 2.0.0&&< 2.0.72.0.7cargo update -p cosmwasm-vm --precise 2.0.7
🦀crates.iocosmwasm-vmall versions1.5.8cargo update -p cosmwasm-vm --precise 1.5.8
🐹Gogithub.com/CosmWasm/wasmvm/v2≥ 2.1.0&&< 2.1.32.1.3go get github.com/CosmWasm/wasmvm/v2@v2.1.3
🐹Gogithub.com/CosmWasm/wasmvm/v2≥ 2.0.0&&< 2.0.42.0.4go get github.com/CosmWasm/wasmvm/v2@v2.0.4
🐹Gogithub.com/CosmWasm/wasmvmall versions1.5.5go get github.com/CosmWasm/wasmvm@v1.5.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cosmwasm-vm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cosmwasm-vm to 2.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vmqh-5232-v43r is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

# CWA-2024-008 **Severity** Medium (Moderate + Likely)[^1] **Affected versions:** - wasmvm >= 2.1.0, < 2.1.3 - wasmvm >= 2.0.0, < 2.0.4 - wasmvm < 1.5.5 - cosmwasm-vm >= 2.1.0, < 2.1.4 - cosmwasm-vm >= 2.0.0, < 2.0.7 - cosmwasm-vm < 1.5.8 **Patched versions:** - wasmvm 1.5.5, 2.0.4, 2.1.3 - cosmwasm-vm 1.5.8, 2.0.7, 2.1.4 ## Description of the bug (Blank for now. We'll add more detail once chains had a chance to upgrade.) ## Patch - 1.5: https://github.com/CosmWasm/cosmwasm/commit/edcdbc520d4f5521eed42de6e2869658278e91fd - 2.0: https://github.com/CosmWasm/cosmwasm/commit/f63429ca59eb
O3 Security · Impact-Aware SCA

Is GHSA-vmqh-5232-v43r in your dependencies?

Find it across crates.io, Go, including transitive dependencies.

Panic in wasmvm can slow down block production