NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

wasmvm: Malicious smart contract can crash the chainGHSA-23qp-3c2m-xx6w

Fix: CosmWasm/wasmvm@0aefa4c

GHSA-23qp-3c2m-xx6w is a security vulnerability in github.com/CosmWasm/wasmvm. A fix is available for github.com/CosmWasm/wasmvm — see the affected versions and patch details below.

Also known asGO-2025-3448
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Feb 6, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🐹github.com/CosmWasm/wasmvm🐹github.com/CosmWasm/wasmvm/v2🐹github.com/CosmWasm/wasmvm/v2🐹github.com/CosmWasm/wasmvm/v2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

CWA-2025-001

Severity

Medium (Moderate + Likely)1

Affected versions:

  • wasmvm >= 2.2.0, < 2.2.2
  • wasmvm >= 2.1.0, < 2.1.5
  • wasmvm >= 2.0.0, < 2.0.6
  • wasmvm < 1.5.8

Patched versions:

  • wasmvm 1.5.8, 2.0.6, 2.1.5, 2.2.2

Description of the bug

The vulnerability can be used to crash the chain. The underlying bug that causes this is present on both permissioned and premissionless chains, but it can only be triggered reliably with a malicious contract, so permissioned chains are much less likely to be affected.

(We'll add more detail once chains had a chance to upgrade.)

Patch

Applying the patch

The patch will be shipped in releases of wasmvm. You can update more or less as follows:

  1. Check the current wasmvm version: go list -m github.com/CosmWasm/wasmvm
  2. Bump the github.com/CosmWasm/wasmvm dependency in your go.mod to one of the patched version depending on which minor version you are on; go mod tidy; commit.
  3. If you use the static libraries libwasmvm_muslc.aarch64.a/libwasmvm_muslc.x86_64.a, update them accordingly.
  4. Check the updated wasmvm version: go list -m github.com/CosmWasm/wasmvm and ensure you see 1.5.8, 2.0.6, 2.1.5 or 2.2.2.
  5. Follow your regular practices to deploy chain upgrades.

While the fix for this issue is not consensus breaking, the patch contains another consensus breaking fix and requires a coordinated upgrade.

Acknowledgement

This issue was found by meadow101 who reported it to the Cosmos Bug Bounty Program on HackerOne.

If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.

Timeline

  • 2024-11-25: Confio receives a report through the Cosmos bug bounty program maintained by Amulet.
  • 2024-11-28: Confio security contributors confirm the report.
  • 2024-11-28: Confio developed the patch internally.
  • 2025-02-04: Patch gets released.

Footnotes

  1. following Amulet's Severity Classification Framework ACMv1.2: https://github.com/interchainio/security/blob/0295254e8645301ccb606d46108a45cede0a73e0/resources/CLASSIFICATION_MATRIX.md ↩

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/CosmWasm/wasmvmall versions1.5.8go get github.com/CosmWasm/wasmvm@v1.5.8
🐹Gogithub.com/CosmWasm/wasmvm/v2≥ 2.0.0&&< 2.0.62.0.6go get github.com/CosmWasm/wasmvm/v2@v2.0.6
🐹Gogithub.com/CosmWasm/wasmvm/v2≥ 2.1.0&&< 2.1.52.1.5go get github.com/CosmWasm/wasmvm/v2@v2.1.5
🐹Gogithub.com/CosmWasm/wasmvm/v2≥ 2.2.0&&< 2.2.22.2.2go get github.com/CosmWasm/wasmvm/v2@v2.2.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/CosmWasm/wasmvm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/CosmWasm/wasmvm to 1.5.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-23qp-3c2m-xx6w is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

# CWA-2025-001 **Severity** Medium (Moderate + Likely)[^1] **Affected versions:** - wasmvm >= 2.2.0, < 2.2.2 - wasmvm >= 2.1.0, < 2.1.5 - wasmvm >= 2.0.0, < 2.0.6 - wasmvm < 1.5.8 **Patched versions:** - wasmvm 1.5.8, 2.0.6, 2.1.5, 2.2.2 ## Description of the bug The vulnerability can be used to crash the chain. The underlying bug that causes this is present on both permissioned and premissionless chains, but it can only be triggered _reliably_ with a malicious contract, so permissioned chains are much less likely to be affected. (We'll add more detail once chains had a chance to upgr
O3 Security · Impact-Aware SCA

Is GHSA-23qp-3c2m-xx6w in your dependencies?

Find it across Go, including transitive dependencies.

wasmvm: Malicious smart contract can crash the chain