Drupal Cross-site scripting (XSS) vulnerabilityGHSA-vhg8-x858-7wq6
MEDIUMGHSA-vhg8-x858-7wq6 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in Drupal 8.x before 8.1.10 allows remote attackers to inject arbitrary web script or HTML via vectors involving an HTTP exception.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.1.10 | 8.1.10composer require drupal/core:^8.1.10 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.1.10 | 8.1.10composer require drupal/drupal:^8.1.10 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vhg8-x858-7wq6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-vhg8-x858-7wq6 in your dependencies?
Find it across Packagist, including transitive dependencies.