NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

silverstripe/framework sends passwords back to browsers under some circumstancesGHSA-vh7q-j8p5-2h4h

LOWFix: silverstripe/silverstripe-framework@c28f411

GHSA-vh7q-j8p5-2h4h is a low-severity (CVSS 3.5) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘silverstripe/framework🐘silverstripe/framework🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Under some circumstances a form may populate a PasswordField with submitted data, reflecting submitted data back to a user. The user will only see their own submissions for password data, which is not considered best practice. We are not aware of data leaks to other users, devices or sessions.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 3.5.5-rc1&&< 3.7.03.7.0composer require silverstripe/framework:^3.7.0
🐘Packagistsilverstripe/framework≥ 4.0.3-rc1&&< 4.0.44.0.4composer require silverstripe/framework:^4.0.4
🐘Packagistsilverstripe/framework≥ 4.1.0-rc1&&< 4.1.14.1.1composer require silverstripe/framework:^4.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 3.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vh7q-j8p5-2h4h is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Under some circumstances a form may populate a PasswordField with submitted data, reflecting submitted data back to a user. The user will only see their own submissions for password data, which is not considered best practice. We are not aware of data leaks to other users, devices or sessions.
O3 Security · Impact-Aware SCA

Is GHSA-vh7q-j8p5-2h4h in your dependencies?

Find it across Packagist, including transitive dependencies.

GHSA-vh7q-j8p5-2h4h: framework — Fixed in 3.7.0