NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Flow Bugfix Releases for Entity SecurityGHSA-vh6j-wv25-8qxr

GHSA-vh6j-wv25-8qxr is a security vulnerability in typo3/flow. A fix is available for typo3/flow — see the affected versions and patch details below.

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

5 pkgs affected
🐘typo3/flow🐘typo3/flow🐘typo3/flow🐘typo3/flow🐘typo3/flow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

If you had used entity security and wanted to secure entities not just based on the user's role, but on some property of the user (like the company he belongs to), entity security did not work properly together with the doctrine query cache. This could lead to other users re-using SQL queries from the cache which were built for other users; and thus users could see entities which were not destined for them.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/flow≥ 3.0.0&&< 3.0.123.0.12composer require typo3/flow:^3.0.12
🐘Packagisttypo3/flow≥ 3.1.0&&< 3.1.103.1.10composer require typo3/flow:^3.1.10
🐘Packagisttypo3/flow≥ 3.2.0&&< 3.2.133.2.13composer require typo3/flow:^3.2.13
🐘Packagisttypo3/flow≥ 3.3.0&&< 3.3.133.3.13composer require typo3/flow:^3.3.13
🐘Packagisttypo3/flow≥ 4.0.0&&< 4.0.64.0.6composer require typo3/flow:^4.0.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/flow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/flow to 3.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vh6j-wv25-8qxr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

If you had used entity security and wanted to secure entities not just based on the user's role, but on some property of the user (like the company he belongs to), entity security did not work properly together with the doctrine query cache. This could lead to other users re-using SQL queries from the cache which were built for other users; and thus users could see entities which were not destined for them.
O3 Security · Impact-Aware SCA

Is GHSA-vh6j-wv25-8qxr in your dependencies?

Find it across Packagist, including transitive dependencies.

Flow Bugfix Releases for Entity Security