CVE-2013-7082 — flow
CVE-2013-7082 is a Cross-site Scripting (XSS) vulnerability in neos/flow. A fix is available for neos/flow — see the affected versions and patch details below.
TYPO3 Flow Cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
neos/flow🐘neos/flow🐘typo3/flow🐘typo3/flowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the errorAction method in the ActionController base class in TYPO3 Flow (formerly FLOW3) 1.1.x before 1.1.1 and 2.0.x before 2.0.1 allows remote attackers to inject arbitrary web script or HTML via unspecified input, which is returned in an error message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | neos/flow | ≥ 1.1.0&&< 1.1.1 | 1.1.1composer require neos/flow:^1.1.1 |
| 🐘Packagist | neos/flow | ≥ 2.0.0&&< 2.0.1 | 2.0.1composer require neos/flow:^2.0.1 |
| 🐘Packagist | typo3/flow | ≥ 1.1.0&&< 1.1.1 | 1.1.1composer require typo3/flow:^1.1.1 |
| 🐘Packagist | typo3/flow | ≥ 2.0.0&&< 2.0.1 | 2.0.1composer require typo3/flow:^2.0.1 |
Affected Products
flowtypo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neos/flow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neos/flow to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-7082 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2013-7082 in your dependencies?
Find it across Packagist, including transitive dependencies.