Craft CMS' anonymous "assets/image-editor" calls return private asset editor metadata to unauthorized usersGHSA-vgjg-248p-rfm2
Fix: craftcms/cms@d30df31GHSA-vgjg-248p-rfm2 is a Information Exposure vulnerability in craftcms/cms. A fix is available for craftcms/cms — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-vgjg-248p-rfm2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
craftcms/cms🐘craftcms/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A low-privileged authenticated user can call assets/image-editor with the ID of a private asset they cannot view and still receive editor response data, including focalPoint.
The endpoint returns private editing metadata without per-asset authorization validation.
Root-cause analysis:
actionImageEditor()acceptsassetIdfrom the request body.- The asset is loaded, and the focal-point data is read.
- Response returns
htmlandfocalPoint. - No explicit authorization check is applied before the response.
Impact
Affected deployments:
- Craft sites where asset edit metadata should remain restricted to authorized users.
Security consequence:
- Unauthorized users can extract private editor metadata and related editor context for inaccessible assets.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/cms | ≥ 5.0.0-RC1&&< 5.9.14 | 5.9.14composer require craftcms/cms:^5.9.14 |
| 🐘Packagist | craftcms/cms | ≥ 4.0.0-RC1&&< 4.17.8 | 4.17.8composer require craftcms/cms:^4.17.8 |
Affected Products
craft cmscraftcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/cms to 5.9.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vgjg-248p-rfm2 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-vgjg-248p-rfm2 in your dependencies?
Find it across Packagist, including transitive dependencies.